手动集成
要将 Unity 游戏发布到 Apps in Toss,需要将 Unity 项目 WebGL构建为 WebGL。本指南将介绍在 Unity 中创建 WebGL 构建的基本方法。
1. 安装 WebGL 模块
需要在 Unity Hub 中安装 WebGL 平台。
运行 Unity Hub
选择 Installs 选项卡
点击正在使用的 Unity 版本旁边的三个点(···) → Add Modules
勾选 WebGL Build Support → 安装
安装完成后,在 Unity 中进入 File > Build Settings 时,平台列表中会出现 WebGL。
2. 切换平台
打开 Unity 项目
前往 File > Build Settings
选择 WebGL → 点击 Switch Platform
3. 调整 Player 设置
请在 Edit > Project Settings > Player 菜单中设置以下项目。
Publishing Settings
Compression Format:
Brotli设置为
4. 进行构建
前往 File > Build Settings
在已选中 WebGL 的状态下 → 点击 Build
指定输出文件夹(例如:Build/)
5. 查看结果
构建完成后,通常会生成 index.html, Build, TemplateData 文件夹。根据 Unity 项目设置或版本不同,生成的文件夹可能会略有差异。可以将这些文件夹包含到 Vite 项目中,以网页形式展示。
关于如何用 Vite 包装 Unity WebGL,请参考如何用 Vite 包装 Unity WebGL。
最后更新于
这有帮助吗?